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OpenXR

OpenXR to wolny od opfat, otwarty standard, ktéry zapewnia wspolny zestaw
interfejséw API do tworzenia aplikacji XR dziatajgcych na szerokiej gamie urzadzen
AR i VR. Dzigki temu skraca sie czas i koszty potrzebne deweloperom na
dostosowanie rozwigzan do poszczegdélnych platform XR, a jednoczesnie tworzy sie
wiekszy rynek tatwo wspieranych aplikacji dla producentow urzadzen
wykorzystujgcych standardy OpenXR.

Przed opracowaniem OpenXR, deweloperzy musieli pisa¢ kod oddzielnie dla
kazdego obstugiwanego urzadzenia na rynku. Dzieki OpenXR deweloperzy maja
teraz dostep do jednego, wydajnego, wieloplatformowego interfejsu API, ktory
umozliwia im stworzenie rozwigzania raz, a nastepnie tatwe przeniesienie i
optymalizacje go. To pozwala dotrze¢ do wiekszej liczby uzytkownikéw, nie
rezygnujac z innowacyjnych funkcji konkretnych platform poprzez rozszerzenia i
warstwy APl OpenXR.
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Before OpenXR: Applications and engines needed separate
proprietary code for each device on the market.

Zrédto: https://www.khronos.org/api/index_2017/openxr
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OpenXR provides a single cross-platform, high-performance
APl between applications and all conformant devices.

Zrédio: https://www.khronos.org/api/index_2017/openxr

OpenXR standaryzuje uzywanie wielu roznych urzadzen XR na wielu platformach, w
tym:

Wyswietlacze nagtowne

Kontrolery

Stacje bazowe

Urzadzenia sSledzace: ciato, dtonie, obiekty, oczy itd.

Urzadzenia haptyczne

Silniki gier

Infrastrukture chmurowa/5G

| wiele innych



Unity

Unity to zaawansowany silnik do tworzenia gier i aplikacji interaktywnych, ktéry
wspiera zaréwno projekty 2D, jak i 3D. Oferuje bogate srodowisko do programowania
w jezyku C#, co pozwala na tworzenie skryptow sterujgcych logikg gry oraz
interakcjg z obiektami.

Silnik korzysta z komponentowego modelu architektury, co umozliwia elastyczne
dodawanie i modyfikowanie zachowan obiektéw w scenie. Unity zawiera wbudowany
silnik fizyczny, ktory obstuguje kolizje, symulacje ruchu oraz zachowania ciat statych,
co pozwala na realistyczne odwzorowanie dynamiki obiektéw.

Unity jest kompatybilne z wieloma platformami, w tym Windows, macOS, Linux,
Android, iOS, a takze VR/AR, co utatwia rozwoj aplikacji wieloplatformowych. Dzieki
Asset Store deweloperzy majg dostep do szerokiej gamy zasobow, wtyczek i
narzedzi, co przyspiesza proces tworzenia.

W trakcie zajec laboratoryjnych wykorzystywana bedzie wersja 6000.2.6f2 silnika.

2.1. XR Interaction Toolkit

Pakiet XR Interaction Toolkit to zestaw narzedzi oraz system interakcji na wysokim
poziomie, oparty na komponentach, przeznaczony do tworzenia doswiadczen VR i
AR. Zapewnia solidng podstawe, ktéra umozliwia interakcje 3D i interfejsu
uzytkownika na podstawie zdarzen wejsciowych silnika. Rdzeniem tego systemu jest
zestaw podstawowych komponentéw: “Interactor” i “Interactable” oraz Menedzer
Interakcji, ktory tgczy te dwa typy komponentow. Pakiet zawiera réwniez komponenty,
ktére mozna wykorzysta¢ do lokomogiji i wizualizaciji.

Pakiet zawiera zestaw komponentdéw, umozliwiajgcych miedzy innymi:

Obstuge wielu platform: Meta Quest, OpenXR, visionOS itd.

Podstawowe interakcje z obiektami: unoszenie, wybor i chwytanie

Haptyczne wibracje dla kontroleréw XR

Wizualne informacje (pod$wietlenie, renderowanie linii) wskazujgce mozliwe i
aktywne interakcje

Podstawowe interakcje z ptétnem Ul

Narzedzia do interakcji z XR Origin, szkieletem kamery VR do obstugi doswiadczen
stacjonarnych i w skali pomieszczenia

XR Interaction Toolkit udostepnia tez symulator urzgdzenia XR: komponent, ktory
umozliwia prace nad aplikacjg XR bez posiadania docelowego sprzetu, lub po prostu
testowanie jej bez potrzeby zaktadania urzadzenia na gtowe. Symulator nie
manipuluje bezposrednio obiektami wchodzgcymi w skiad szkieletu XR Origin,
zamiast tego symuluje urzadzenia wejsciowe, takie jak headset lub kontrolery.

W trakcie zajec laboratoryjnych pakiet uzywany bedzie w wersiji 3.2.1.



2.2. Utworzenie projektu

Aby utworzy¢ nowy projekt Unity, nalezy skorzystaé z programu Unity Hub. Na
poczatek upewnij sie, ze zainstalowana jest odpowiednia wersja Unity: 6000.2.6f2.

?Hub
Installs Search Locate | Install Editor
W Getsetup
All
Projects

= Installs
UNITY 6

Learn

% Unity 6.2 (6000.2.6f2) Supported @ Manage

Resources
C:\Program Files\Unity\Hub\Editor\6000.2.6f2\Editor\Unity.exe

Licenses Android  Windows

Settings

Kolejnym krokiem jest utworzenie nowego projektu w zaktadce Projects.

2Hub
Projects ~ |+ New project

W Getsetup

& Projects s © D Modified 7 Editor version o]
Installs
Learn
Resources

Licenses

Settings

Unity umozliwia przygotowanie projektu VR na dwa sposoby: gotowy szablon
projektu dla aplikacji VR, AR oraz MR (Mixed Reality) oraz reczna instalacja
potrzebnych pakietéw. Podczas gdy skorzystanie z gotowego szablonu jest szybsze,
moze okazac sie, ze pobieramy niepotrzebne zasoby. Przygotowanie projektu od



podstaw pozwala na wiekszg swobode w doborze pakietéw, odrzucenie zbednych
zasobodw, a zarazem zmniejszenie skomplikowania projektu na start. Na potrzeby
laboratorium oraz w celu zrozumienia zaleznosci pomiedzy danymi komponentami,
ponizej zostaje przedstawiona druga opcja.

W oknie nowego projektu, wybierz szablon “Universal 3D”, nadaj nazwe projektowi,
wybierz folder docelowy i nacisnij “Create project”.

2Hub
New project

W Getsetup Universal 3D

This template includes the settings and assets you
9 Projects need to start creating with the Universal Render
Templates Pipeline (URP).

Installs

your prc ® Read more

Learn
Editor version

Unity organization
Resources % 6000.2.6f2 Supported

Licenses
% Core p Project name

) RWIR.LAB-01
Location

D:\Unity

U SRP Use Unity Version Control

Settings Universal 2D Universal 3D

-+ Create project

Program Unity Hub utworzy nowy projekt, zainstaluje odpowiednie zaleznosci, a
nastepnie wyswietli okno edytora.

© RWIRLAB-01 - SampleScene -

s - Unity 2022.3.5061 <DX11> -




Teraz nalezy zainstalowac¢ XR Interaction Toolkit oraz potrzebne wtyczki. W oknie
edytora wybierz Window > Package Management > Package Manager, a w
wyswietlonym oknie menedzera znajdz pakiet com.unity.feature.vr w rejestrze (Unity
Registry). Wybierz pakiet z listy i zainstaluj go.

Window  Help
Layouts >
Panels >
Next Window Ctrl+Tab
Previous Window Ctrle Shift+ Tab c) v Filters =

General

20
Accessibility
Al

Analysis
Animation
Audio
Multiplayer
Package Manager
My Assets

Package Management
Rendering

Search Services Ctrl+0
SELNEDE Asset Store
Text
TextMeshPro
Ul Toolkit

Version Control

Visual Scripting

Po instalacji pakietu Unity moze zapyta¢ o automatyczng naprawe niektérych
ustawien. Mozna na razie zignorowac tg wiadomos$c¢ lub zgodzi¢ sie na tg zmiane za
pomoca przycisku “Fix All”.

Project Validation
dation

Turn Off

Po instalacji pakietu nalezy jeszcze raz odnalez¢ go w menedzerze pakietow
(com.unity.xr.interaction.toolkit) i zaimportowac Starter Assets - jest to zestaw
zasobow utatwiajgcych ustawienie projektu.



Built-in

Unlock

Import

Import

Aby moc wykorzystywac urzgdzenie HTC Vive Pro oraz inne urzadzenia wspierajgce
backend OpenXR, przejdz do Project Settings > XR Plug-in Management i w sekgji
“Plug-in Providers” zaznacz opcje przy OpenXR.

Edit Assets GameObject Component Services Jobs Window Help

I Undo Medified Run In Background ... Ctrl+Z
Redo Ctrl+¥
Cut Ctrl+X
Copy CtrlsC v Filters ¥
Paste Ctrl+V
Paste Special 3
Duplicate Ctrl+D
Rename
Delete Del

Frame Selected in Scene

Frame Selected in Window under Cursor F
Lock View to Selected Shift+F
Select All Ctrl+A
Deselect All Shift+D
Select Children Shift+C
Select Prefab Root Ctrl+Shift+R
Invert Selection Ctrl+l
Selection Groups 3
Lighting >
Search >
Play Mode »
Graphics Tier »
Rendering »

Clear All PlayerPrefs

Project Settings...

Preferences...

R



Po zainstalowaniu wtyczki nalezy ponownie przejs¢ do sekcji rozwigzywania
probleméw: Project Settings > XR Plug-in Management > Project Validation.

ve Performance Project Validation
Scene Validation

Turn Off

Validation Rules

(|

Issues (3) of Checks (9)

Timeline

Validation
ction Toolkit

Pierwszy problem zwigzany jest z dodaniem profilu interakcji, co zostanie
przedstawione w dalszej czesci instrukcji. Pozostate dwa problemy mozna naprawi¢
automatycznie, klikajgc przycisk Fix przy nich.

Aby dodac¢ nowy profil interakcji dla kontroleréw urzgdzenia HTC Vive Pro, przejdz do
Project Settings > XR Plug-In Management > OpenXR, a nastepnie w sekcji
Enabled Interaction Profiles dodaj profil HTC Vive Controller Profile. Mozesz
dodac¢ tutaj dowolng liczbe profili, dla ktérych chcesz dodac wsparcie.

Er i tion Profiles

Li

Meta Quest Touch Pro Controller Profile

OpenXR Feature Groups
Oculus Touch Centroller Profile

All Features Eye Gaze Interaction Profile

HTC Vive Controller Profile

HP Reverb G2 Controller Profile

Valve Index Controller Profile

Micresoft Hand Interaction Profile
Micresoft Motion Controller Profile
Hand Interaction Profile

Meta Quest Touch Plus Controller Profile

Khronos Simple Controller Profile

Kolejnym krokiem w ustawieniu kontroleréw bedzie przejscie do Assets > Samples >
XR Interaction Toolkit > 3.2.1 > Starter Assets, wybranie pliku konfiguracyjnego
XRI Default Input Actions.inputactions i ustawienie jako domysiny dla projektu. Plik
ten zawiera ustawienia dotyczace akcji wejscia dla kontrolerow VR i przypisuje



konkretne akcje danym przyciskom i czujnikom urzadzenia. Temat systemu wejscia
zostanie poruszony na przysztych laboratoriach.

@? RWIR.LAB-01 - SampleScene - Windows, Mac, Linux - Unity 8.2 (6000.2.6f2) <DX12» — a X

File Edit Assets GameObject Component Services Jobs Window Help

& Unity 6
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Jesli chcesz skorzysta¢ z symulatora, przejdz do Project Settings > XR Plug-in
Management > XR Interaction Toolkit i zaznacz Use XR Device Simulator in
scenes. Zaznaczenie tej opcji spowoduje zainstalowanie dodatkowych zasobdw.

e Performance XR Interaction Toolkit

XR Device Simulator Settings

Interaction Layer Settings
= Lay < In Ins }

Interaction Layers

Importing XR Device Simulator sample, n

The %R Device Simulator sample is going to be imported
from the ¥R, Interaction Toolkit package, press "0k to
continue,




Ustawienia silnika zostaty poprawnie zaaplikowane, teraz nalezy przejs¢ do ustawienia
sceny. Mozna utworzy¢ nowg scene (File > New Scene lub skrét Ctrl + N) lub
skorzystac ze sceny SampleScene. Z drzewa obiektow usun Main Camera, a
nastepnie dodaj nowy obiekt klikajgc prawym przyciskiem myszy na drzewo: XR > XR
Origin (VR). Automatycznie zostanie dodany rowniez XR Interaction Manager.

f? XR Origin (VR)

Ctrl+X
Copy Ctrl+C
Paste Ctrl+V
Paste Special
Rename
Duplicate
Delete
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Dezelect All
Invert Selection

Select Children
Find References in Scene

Set as Default Parent

Create Empty Ctrl+5Shift+ M Direct Interactor

20 Object » (Gaze Interactor

3D Object -] Grab Interactable
Effects * Interactable Snap Volume
Light » Interaction Manager
Audio » Mear-Far Interactor
Video * Ray Interactor

Ul -] Socket Interactor

Al » Teleportation Anchor
Ul Toolkit -] Teleportation Area
Rendering b Ul Canvas

Volume » Ul Event System

#R - #R Crigin (VE)

XR Origin (XR Rig) to obiekt, ktory reprezentuje przestrzen uzytkownika. W jego
hierarchii znajduje sie Camera Offset, obiekt stuzgcy ustaleniu poczgtkowej odlegtosci
sledzonych obiektow od podtogi - dlatego obiekt Main Camera reprezentujgcy gtowe
uzytkownika znajduje sie bezposrednio w hierarchii Offsetu. Wszelkie inne obiekty
stanowigce cyfrowg reprezentacje sledzonych urzadzen, takie jak kontrolery VR,
réwniez tutaj zostang umieszczone.



Obiekt kamery Main Camera otrzymat przy tworzeniu dodatkowy komponent Tracked
Pose Driver (Input System). Ten komponent automatycznie aktualizuje pozycije i
obrot obiektu kamery na podstawie danych z zestawu HMD: pozycja zmienia sie na
podstawie akcji <XRHMD>/centerEyePosition, a obrét na podstawie akcji
<XRHMD>/centerEyeRotation.

s Tracked Pose Driver (Input System)

Ratation And Paosition

ation [HandheldARInputDeavi

Action e+

trackingState [XR HMD]

Tak ustawiony projekt jest gotowy do uzytku.



Zadania

Utworz nowy projekt i ustaw scene dla twojego urzadzenia VR wedtug instrukgiji.
[1 pki]

Dodaj kilka dowolnych obiektow dookota kamery i rozejrzyj sie. [1 pkt]
Przyktadowa scena:

4.

Korzystajgc z zaimportowanych zasobéw startowych, mozesz zaimportowac gotowy
XR Origin zamiast tworzy¢ nowy od zera. Przeciggnij prefabrykat XR Origin (XR
Rig) z folderu Assets/Samples/XR Interaction Toolkit/3.2.1/Starter
Assets/Prefabs do hierarchii sceny oraz rozpakuj go (opcja Prefab>Unpack w
menu kontekstowym obiektu) Nastepnie dodaj do sceny dwie ré6znokolorowe kule,
ktére beda “przyklejone” do twoich kontroleréw ruchu i bedg porusza¢ sie razem z
nimi, gdy poruszysz dtomi [3 pkt].

Zrodia

Dokumentacja XR Interaction Toolkit:
https://docs.unity3d.com/Packages/com.unity.xr.interaction.toolkit@3.0/manual/index.html
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